Lenteurs de l'application

CzygenCzygen Member
Bonjour
J'ai une base de plus de 2000 films (la base pèse 235Mo) et j'ai parfois sur un iMac des temps de réponse très longs pouvant aller jusque 10 à 15 secondes. Ceci m'arrive notamment lorsque 
  • je maintiens l'application ouverte assez longtemps (plusieurs jours)
  • une sauvegarde de mes données  est en fonctionnement (Time machine, ...)
  • et parfois au chargement de la base

Ma deuxième base, pour l'instant beaucoup plus petite (mois de 300 films et 30Mo) ne me pose pas ce genre de problème.
J'ai essayé de sauvegarder puis restaurer la base mais ça ne change rien
Pourriez-vous SVP m'indiquer une piste pour pallier ce dysfonctionnement ?
Merci d'avance

Réponses

  • CarlBernardCarlBernard Member
    10 sept. modifié
    Je ne sais ce que Pascal en pense, mais globalement je mettrais plutôt en cause la "puissance" de ton iMac.
     "je maintiens l'application ouverte assez longtemps", ça doit venir de la manière dont l'OS gère les applis en attente, ça ne me parait pas anormal.
     "une sauvegarde de mes données  est en fonctionnement (Time machine, ...)", c'est assez normal, Time machine doit utiliser pas mal de mémoire, etc., donc il en reste peu pour les autres applis.
    J'ai fait un essai sur mon vieux MacBookpro de 2010 (processeur 2,4 Ghz, intel core2, 8Go de mémoire, DD classique, et je suis resté sous El Capitan)) avec une base de plus de 2000 films (j'ai en fait dupliquer 4 fois une de mes base dans un profil essai). C'est vrai que la sauvegarde prend un peu plus de temps qu'avec une base de 500 films, mais c'est normal , et en plus sur mon vieux mac (il faudra que je fasse un essai sur le PC de mon épouse qui est beaucoup plus puissant).
    Mais autrement Filmotech fonctionne normalement.
    Alors est-ce que tu peux "optimiser" ton iMac? Je n'ai pas trop d'idée (et de ce que valent les logiciels payants), à part Onyx, ou faire un clone Carbon copy cloner et le recopier sur ton DD (ça doit défragmenter les fichiers), mais s'il manque de la "puissance"....Restaurer le système et les fichiers avec Time machine ?, je n'ai pas trop d'idée non plus.
  • CzygenCzygen Member
    Bonjour
    Merci CarlBernard pour cette réponse mais je ne pense pas que ce soit lié à un problème de Mac. Il est récent, le système aussi, le disque est un fusionDrive et je fais régulièrement des maintenances avec Onyx.
    De mon point de vue d'ancien professionnel de l'informatique, c'est un problème d'optimisation de la base de données qui est maintenant assez ancienne et doit nécessiter quelques purges et recompression. Je ne sais par contre pas comment faire avec la base SQLlite utilisée.
    Si quelqu'un connait la manière merci d'avance, ça m'évitera de passer trop de temps à chercher
  • Bonjour Czygen,
    Je suis vraiment désolé d'avoir été complètement à côté de la plaque !
    Une idée qui vaut ce qu'elle vaut, mais il vaudrait qd m mieux demander à Pascal (@Filmotech).
    Exporter la base par ex en XML et la réimporter dans un nouveau profil (elle peut se reconstruire  ?? - surtout que le données et les affiches sont séparées dans l'exportation ...). 
    J'ai fait un essai avec une base de 455 films, 38,3 Mo; après réimportation dans un nouveau profil elle fait 37,2 Mo.
    Mais bon...
    Cordialement.
  • Manifestement l'ID est reconstruit (j'imagine les autres index dans la foulée). Pour les données ?
    Est-ce que ça peut être suffisant pour améliorer la performance de la base ?
  • FilmotechFilmotech Administrator
    22 sept. modifié
    Une des choses qui peuvent plomber les performances de la base ce sont les affiches et une base fragmentée.

    En SQLite il existe une commande VACUUM qui permet de défragmenter la base (il faut utiliser un outil SQLite pour exécuter cette requête). Mais, comme le suggère CarlBernard, tu peux aussi faire un export/import en XML et recréer une nouvelle base.

    Je ne suis pas sûr que ça résolve ton souci, mas c'est une chose à tester.
  • CarlBernardCarlBernard Member
    22 sept. modifié
    J'ai fait un essai avec VACCUM (=Full) dans les pragmas. Ma base (la sauvegarde) est passée de 38,3 à 37,2 Mo, donc comme avec export/ import en XML ; mais elle est sans doute peu fragmentée... (J'utilise BD browser for SQLite, gratuit et pratique).
    Bon, j'ai appris une commande !
    NB : J'ai restauré la sauvegarde défragmentée avec VACCUM : l'ID n'est pas modifié par rapport à la base originelle, comme il est dit dans la doc; donc le passage de 38,3 à 37,2 Mo ne serait dû qu'à la fragmentation ...
Connectez-vous ou Inscrivez-vous pour répondre.

Sites Partenaires : | PLUCHON.COM | Xojo | Hébergement IONOS (1&1) | Price Minister | iGraal |

Informations légales | Contact

© 2004-2019 Pascal PLUCHON