Problème importation de films

Floflo85Floflo85 Member
Bonjour,

J'ai récemment un problème pour importer les films. En effet, lorsque je veux en mettre un dans ma liste depuis l'onglet "importer" puis "scan disque". Filmotech me mets toute ma liste que j'ai déjà et suis dans l'obligation de tout décocher afin d'enregistrer le film souhaité. Je vous remercie d'avance de votre aide. :) 


Dans l'attente de vous lire.
«1

Réponses

  • FilmotechFilmotech Administrator
    Le volume a-t-il changé de nom ?
  • Floflo85Floflo85 Member
    1 oct. modifié
    Bonjour,

    Le répertoire initiale n'a pas changé de nom. Y a t-il un bug dans la nouvelle version ? Pour info cela ne m'a jamais fait avant.

    Merci de votre aide et d'avoir pris le temps de me répondre.

    NB : le programme est vraiment bien fait. Grand respect au programmateur B)  
  • CarlBernardCarlBernard Member
    1 oct. modifié
    Un bug ? Je ne pense pas, du moins sur mac : je viens de faire un essai, pas de pb avec les films déjà enregistrés (3.81 ou bêta3.82)
  • @Filmotech Pascal, je viens de faire un essai sur PC (W10) (Filmotech 3.81); y-a un pb, à l'importation je ne vois aucun de mes fichiers vidéos (mp4 ou mov en gl) ! ex:

  • FilmotechFilmotech Administrator
    Il me semble que quand tu sélectionnes un dossier, Windows ne montre pas le contenu dossier (sauf s'il y a des sous-dossier)
  • CarlBernardCarlBernard Member
    1 oct. modifié
    Filmotech a dit :
    Il me semble que quand tu sélectionnes un dossier, Windows ne montre pas le contenu dossier (sauf s'il y a des sous-dossier)
    OK, mais quand j'ouvre un sous-dossier, je devrais voir son contenu, s'il y a des mp4 pour importer, ex avec l'explorateur (même sous-dossier que ci-dessus):

  • Floflo85Floflo85 Member
    Pour ma part, j'ai également la 3.8.1 sur Windows 10.  Je voudrai savoir svp s'il y a possibilité d'importer une vidéo au cas par cas ?


  • @Floflo85 Si je comprends bien, toi tu vois tes vidéos (donc tu peux les importer...), alors que moi je ne les vois pas sous W10 (et je ne vois vraiment pas ce que je peux faire comme mauvaise manip) (surtout que ça marche sur mac).
  • @Filmotech Alors, c'est "marc de café" !
    Je ne vois pas les fichiers vidéos (comme dans la copie écran ci-dessus, avec le message), mais si je clique sur "sélectionner un dossier", filmotech propose les fichiers à l'importation, en plus en désélectionnant les fichiers déjà importés !
  • Floflo85Floflo85 Member
    En effet, lorsque je scanne mon dossier, il me mets toutes les vidéos qui sont déjà enregistrées pas les récentes.  

    Pareil, je ne vois pas la mauvaise manip que j'ai pu faire :) 

    Attendons la réponse de l'administrateur :o
  • Floflo85 a dit :
    En effet, lorsque je scanne mon dossier, il me mets toutes les vidéos qui sont déjà enregistrées pas les récentes. 
    Oui, il y a un pb d'affichage, donc il doit bien y avoir un petit bug...
  • CarlBernardCarlBernard Member
    1 oct. modifié
    En fait, sur mac et PC ça fonctionne en final de la même manière (j'ai fait plusieurs essais).
    La seule différence c'est que sur mac on voit tous les fichiers (vidéos ou non) "grisés" et sur PC on n'en voit aucun (sauf les sous-dossiers).
    (et le bouton est "ouvrir" sur mac et "sélectionner un dossier" sur PC - peu approprié ; et après avoir cliqué sur le bouton, c'est la même chose sur les 2 plate-formes : les fichiers déjà enregistrés ne sont pas sélectionnés, les autres oui).
    Pascal, tu as raison, windows ne montre pas les fichiers avec importer - ce qui perturbe au premier abord, avec de plus le message... ! -, mais si tu pouvais faire une modif pour qu'il montre les fichiers vidéos...
  • FilmotechFilmotech Administrator
    1 oct. modifié
    CarlBernard a dit :
    Pascal, tu as raison, windows ne montre pas les fichiers avec importer - ce qui perturbe au premier abord ! -, mais si tu pouvais faire une modif pour qu'il montre les fichiers vidéos...
    C'est le fonctionnement standard du SelectFolder de Xojo, donc je ne peux pas y faire grand chose.
  • Bon, une fois qu'on le sait...
    Et le message "aucun élément ne correspond à votre recherche", tu peux le supprimer ?
  • FilmotechFilmotech Administrator
    1 oct. modifié
    La commande est très basique... Pas de paramètres, pas de personnalisation. https://docs.xojo.com/SelectFolder

    Il faudrait que j'essaye SelectFolderDialog https://docs.xojo.com/SelectFolderDialog, pas sûr que ça change grand chose ;)
  • Floflo85Floflo85 Member
    Et pour le fait que le logiciel ne sélectionne pas es fichiers récents à importer. Y a t'il une méthode pour importer un seul fichier à la fois ? Merci
  • CarlBernardCarlBernard Member
    1 oct. modifié
    Floflo85 a dit :
    Et pour le fait que le logiciel ne sélectionne pas es fichiers récents à importer. Y a t'il une méthode pour importer un seul fichier à la fois ? Merci
    Là c'est bizarre : je vois les fichiers que je rajoute à un répertoire (quand je suis dans "IMPORTER") (on voit également les fichiers qui sont éventuellement dans les sous-répertoires). Ex:
    Un seul fichier ? (il faudrait qu'il soit dans un sous-répertoire du répertoire à partir duquel tu pars, par ex Vidéos ; mais ça me paraît un peu compliqué, parce que s'il te faut un répertoire par fichier !)
    (Comme on ne voit pas les noms des fichiers dans les répertoires, juste avant "importer", c'est difficile de sélectionner qu'un seul fichier...)
    Mais si Pascal a une autre idée...
  • FilmotechFilmotech Administrator
    Normalement tu dois toujours sélectionner le même dossier de départ, pour que les chemins restent identique, et Filmotech ne cochera pour l'import que les films dont le chemin n'est pas déjà en base.
  • Floflo85Floflo85 Member
    A chaque fois que je veux importer un film, il m'importe toute ma liste qui est toute cochée. Y a t il un raccourci pour désélectionner toute la liste ? Merci de votre retour
  • Floflo85 a dit :
    A chaque fois que je veux importer un film, il m'importe toute ma liste qui est toute cochée.
    Alors là c'est pas bien normal ....
    Désélectionner toute la liste, apparemment Pascal n'a pas prévu...
  • Floflo85Floflo85 Member
    Oui ça serait bien qu on puisse de sélectionner la liste. En espérant qu il y aura cette modif pour la prochaine mise a jour. 
  • Ta base est peut-être un peu ancienne ?
    Tu pourrais essayer avec une nouvelle base (dans un nouveau profil) pour voir si c'est le même comportement ?
  • FilmotechFilmotech Administrator
    Alors tu peux faire cet essai : 
    Tu crées un nouveau profil (pour créer une base vide et ne pas polluer ta base actuelle). Tu importes ton dossier avec tous les films (ou un dossier de test avec 1 ou 2 films). Tu refais un second import avec le même dossier : est-ce que les cases sont décochées ?
    Si ce n'est pas le cas, dans la fenêtre d'import, regarde le chemin indiqué (en bout de liste, il faut agrandir la colonne pour voir le chemin en entier). Vérifie dans la fiche du film le chemin mémorisé. Est-ce exactement le même chemin ?
  • Si tu as un petit écran (comme mois sur le mac) ça sera pas évident de lire la dernière colonne dans import (j'ai pas réussi à l’agrandir...), mais tu as le chemin du répertoire de tes fichiers, dans "Messages"/ "Début du prétraitement".

  • Floflo85Floflo85 Member
    Tout d'abord, merci de votre aide !

    Excusez moi mais une question "bête"....de quelle manière fait on pour créer un nouveau profil ? 

    En tout cas, je vais essayer de faire un dossier fictif et mettre quelques vidéos afin de voir si c'est toujours coché par la suite...
  • FilmotechFilmotech Administrator
    Pour créer un nouveau profil  Préférences / Profils et Clique sur le + en bas de la liste (ou par le menu contextuel dans la liste).
    Ensuite tu peux passer d'un profil à un autre depuis la fenêtre principale (menu en haut à droite)
  • Floflo85Floflo85 Member
    Je vous remercie de votre aide et reviens vers vous pour vous dire si cela à fonctionné ou pas...  :)
  • Floflo85Floflo85 Member
    Bonjour,

    Je reviens vers vous concernant mon problème. J'ai crée un autre dossier, et importé quelques vidéos par le "scan disque" ensuite j'ai remis d'autres vidéos dans le même dossier. Malheureusement elles ne sont pas cochées dans la dernière importation mais que les premières, est-ce normal ? merci d'avance.
  • CarlBernardCarlBernard Member
    4 oct. modifié
    Par rapport au test de Pascal, as-tu le même chemin dans "importer" et dans les fiches des films ("lien vers le film" dans "informations support" - double clic sur un titre ou icône "édition") ? ex :
    "importer" (films non cochés car déjà importés) :

    "lien vers le film" pour moissac1984 : (c'est bien le même chemin)

  • Floflo85Floflo85 Member
    Bonjour,

    Merci de ta réponse CarlBernard mais je viens de voir que toutes mes vidéos ne fonctionnent plus lorsque je fais "voir le film". Je ne sais pas ce qu'il sait passé Comment je peux récupérer ma base de donnée avec les liens ? Merci de votre retour .
Connectez-vous ou Inscrivez-vous pour répondre.

Sites Partenaires : | PLUCHON.COM | Xojo | Hébergement IONOS (1&1) | Price Minister | iGraal |

Informations légales | Contact

© 2004-2019 Pascal PLUCHON