Sélection de DVD en vente flash


Promotion DVD 4K | Promotion Disney : 2 DVD pour 20€ | Promotion Disney : 3 DVD pour 25€ | Promotion Disney : 4 DVD pour 30€

Il s'agit d'un lien d'affiliation avec le site marchand.
Cela vous permet d’aider Filmotech.fr sans que cela vous coûte plus cher.
Merci de votre aide !

Publier ma base sur mon PC, en local

Bonjour , je voudrais télécharger le logiciel et récupérer ma base de donnés . Je pars sur un Windows 10 vierge .
Je pose cette question car j'ai déjà fait cet enregistrement de base sur d'autres ordinateurs et je sais qu'il ne faut pas échouer sinon impossible de recommencer.
J'y suis arrivé , mais là sur un autre ordinateur il ne veut pas intégrer ma base.
Pour l'instant je n'ai rien fait donc tout est possible, je sollicite la communauté pour essayer de récupérer cette base .
Merci a tous 

Réponses

  • CarlBernardCarlBernard Member
    24 janv. modifié
    Bonjour,
    Aucune crainte de fausse manoeuvre, on peut tjrs recommencer; il faut juste ne pas perdre la sauvegarde de ta base.
    L'idée:
     - Faire une sauvegarde de ta base sur ton ancien ordi. (c'est un fichier backup... .data)
     - Installer Filmotech sur le nouvel ordi.
     - Dans n'importe quel profil, restaurer la base. (il juste savoir où est ton backup : une clé, un répertoire du nouvel ordi,...)
      (Pour créer un nouveau profil ou supprimer un profil existant : le "+" et le "-" (en bas) ; mais après l'installation tu dois avoir un profil par défaut).
    Ex de Préférences - (ici c'est mon installation, sur mac mais c'est peu différent sur PC):

    NB : tu peux aussi récupérer tes préférences Filmotech sur ton ancien ordi, ex pour les Recherches:
    https://www.filmotech.fr/forum/discussion/279/export-migration-des-requetes-de-recherches#latest
  • Bonsoir merci pour ton aide . J'ai fais la manip... de cette façon plusieurs fois une ou 2 fois réussi . Les autres fois cela n'a pas fonctionné , comme je suis en SQLite je voulais sauvegarder mon travail souvent sur d'autres ordinateurs . Je créais un nouveau compte sur l'ordi en administrateur mais filmotech ne prenais plus mon nouveau backup avec une nouvelle installation de filmotech . Voila pourquoi je me renseigne avant de me lancer. Merci 
  • J'avais filmotech 3.8.2 , faut il prendre cette version ou on peu prendre la dernière 3.9....  merci
  • Ce serait dommage de ne pas utiliser la dernière version de Filmotech.
    Il me semble que les backup fait avec la 3.8 devraient fonctionner avec la 3.9, mais le mieux est que Pascal le précise, @Filmotech ?
  • Bonjour , après un peu d'appréhension je me suis lancer avec la version 3.8.2 et c'est ok . Je pense que mon erreur serait de lancer mon backup sur la base par défaut au lieu d'en créer une . Ensuite j'ai pu supprimer la base défaut . J'essaye de reprendre l'avancé de mon travail sur mes autres ordi . J'ai une version 3.9..... ou je n'avais pas réussi on verra et je reviens vers toi . Merci bien
  • CarlBernardCarlBernard Member
    25 janv. modifié
    Bonjour,
    Ça fait très longtemps que je suis sur Filmotech; je n'ai jamais eu de pb avec les nouvelles versions (je suis maintenant avec la beta 2, 3.10.).
    Quand on installe une nouvelle version, Filmotech garde le répertoire des préférences, donc y compris les bases (ce qui n'empêche pas d'avoir un backup correct, mais je n'en ai jamais eu besoin sur le même ordi.). ("le chemin des préférences" : https://www.filmotech.fr/faq_fr/doku.php/faq/chemin_preferences).
  • Je n'ai hélas pas réussi a rapporter ma base sur un autre ordi . J'ai créer une nouvelle base défaut et essayé d'introduire le backup le lien ce fait mais la base affiche 0 films . Version 3.9.1 , ce n'est pas la version que j'avais qui était 3.8.2 et là je suis sur Windows 11 .
    J'ai suivi le fichier et retrouvé dans les cachés , il est bien dedans mes aucun résultat en nombre de films . Je m'en raimait donc a la communauté pour m'éclairer si possible . Merci  
  • C'est bizarre que "restaurer" ne marche pas.
    J'ai en plus du mac une installation sur W10 qui ne pose pas de pb (version 3.10 beta2).
    J'ai vu sur le forum que certains sont sur W11, sans pb apparent.
    J'espère que Pascal aura une idée. (@Filmotech)
  • J'ai essayé sur un vieil ordi en Windows 7 , création nouvelle base , un fichier backup récent pareil marche pas .
    La base défaut  faite en 2015 garde mes films . L'idée était de construire sur un seul ordi et inclure une sauvegarde bien plus récente sur mes autres ordi . Je préfère rester en interne je ne maitrise pas MYSQL . Merci pour ton aide ..
  • Je n'utilise aussi que des bases SQLite ; je suis sur le forum depuis 2013 - le temps passe !
    Il ne me semble pas avoir eu de pb avec mes bases, même en changeant d'ordi, (y compris entre mac et PC), mais bon,
    Désolé, je n'ai pas trop d'idée...
  • FilmotechFilmotech Administrator
    Le format de la base n'a pas changé depuis des années, donc normalement il doit être possible de récupérer une ancienne base de donnée.
  • Merci , j'ai récupéré ma base principale sur Windows 10 disque vierge c'est déjà cela . C'est peu être moi qui ne maitrise pas correctement .
    Je me contenterait de cela sur un seul ordinateur . A bientôt
  • En principe, compte tenu de ce qui Pascal, on peut restaurer une base sur n'importe quelle version de Filmotech dans n'importe quel profil.

    Ceci étant il faut que la backup contienne des films ! (un backup vide - donc fait sur un profil vide - fait à peu près 33 Ko, sinon on est en Mo).
    C'est un moyen pour vérifier quand on obtient 0 films.
  • Ok je comprends bien mais mon backup contient 76 000 ko . Je ne vois pas ce qui ne colle pas , j'ai  rentré des sauvegardes , je pense 
    ne pas avoir changé de méthode . Simplement  en créant un autre profil  je retrouve les préférences du profil principal dessus . Peut être que cela n'est pas normal .
    Quand on crée un profil il devrait être vierge dans les préférences ou pas ?  merci de ton aide
  • CarlBernardCarlBernard Member
    27 janv. modifié
    bruno562BZ a dit :
    Quand on crée un profil il devrait être vierge dans les préférences ou pas ?  merci de ton aide
    Dans les préférences ? je ne vois pas bien ce que tu veux dire; Oui, la base est vide : on ne voit aucun film dans la liste; Ex avec un nouveau profil Défaut(1):

    Dans les préférences (de l'interface Filmotech) on aura le nom de la base dont on sait qu'elle est vide. Ex, pour Défaut(1):

    Maintenant si tu restaure un backup dans Defaut(1), tu devrais avoir les films que contient le backup.

    Ça marche pas comme ça chez toi ?
  • bruno562BZ a dit :
    Ok je comprends bien mais mon backup contient 76 000 ko . Je ne vois pas ce qui ne colle pas , j'ai  rentré des sauvegardes , je pense 
    ne pas avoir changé de méthode . Simplement  en créant un autre profil  je retrouve les préférences du profil principal dessus . 
    Si tu veux dire que dans ton nouveau profil tu retrouves les films de ton backup (de 76 000ko), c'est tout fait normal, car c'est le but de la manip; mais je ne sais pas si je comprends bien.
  •  Bonjour, excuse j'étais absent , non ça ne marche pas , le chemin de base s'affiche mes pas les films hélas.
    Dans mon backup sur un ordi je retrouve ( 35 000ko  base défaut ) une ancienne sauvegarde . 

    La base nommé ma base ( 76 000 ko ) devrait afficher 76 000 ko avec ses préférences qui ne sont pas du tout identiques a la base défaut hors
    l'affichage est ( 0 ko ) avec les préférences  de la base défaut.
    Si j'ai bien compris rien n'empêche normalement de conserver une base défaut avec des préférences et de saisir une sauvegarde backup plus récente venant d'un autre ordi avec des préférences non identiques a la base défaut .

    Base défaut  / préférence   film 780 - séries 98- disque intenso 2T000  320  )  35 000 ko
    Ma base      /  préférence  documentaires 550 /  variétés 70 / disque Storex  4T000   2318 )   76 000 ko

    C'est juste à titre d'exemple mais je pourrais donc passé d'une base à l'autre avec l'exemple précédent .
    Tu me confirme cela ou pas ?
    Merci à toi
  • CarlBernardCarlBernard Member
    31 janv. modifié
    Avec ce que tu dis ci-dessus, je pense que tu confonds base de données et profil (sans compter les pb des préférences).
    bruno562BZ a dit :
    La base nommé ma base ( 76 000 ko ) devrait afficher 76 000 ko avec ses préférences 
    Tout d'abord, une base de donnée ne peut pas s'appeler ma base, et elle ne comporte aucune préférences.
    Par contre, un profil peut s'appeler ma base, (et il a des préférences associées, cf. par ex les onglets "défaut" ou "tri et affichage")

    Les bases de données de type sqlite créées par Filmotech portent une nom par ex. filmotech_db2022012621464501.data
    (Une base contient essentiellement 2 tables : un tables films (avec les champs (données) : titreVF, acteurs, réalisateurs, etc.) et une table : affiches (comme son nom l'indique); c'est la structure interne, transparente pour l'utilisateur).

    A chaque profil est associé une base (par ex. filmotech_db2022012621464501.data), stockée dans le dossier (répertoire) des "préférences" de Filmotech); ex sur mac (avec mon nom d'utilisateur) : /Users/bernardmaurin/Library/ApplicationSupport/Filmotech/Filmotech_databases/ 
    cf. ma copie d'écran un peu plus haut dans les posts (et encore une fois : https://www.filmotech.fr/faq_fr/doku.php/faq/chemin_preferences pour PC)

    Les préférences servent à afficher les données de la base selon une certaine présentation (paramétrable par l'utilisateur).

    Une sauvegarde est une copie de la base stockée dans un endroit connu (donc a priori plus accessible que le dossier où sont stockées les préférences); son nom est par ex : backup_ma base_2022013100223101.data ; elle ne contient aucune des préférences du profil, ni aucune donnée sur l'ordi, son système, le DD ou autre.
    Dès lors on peut l'utiliser sur n'importe quel ordi (mac ou PC) pourvu qu'on la restaure dans un profil (sur pratiquement n'importe quelle version de Filmotech). (la base associée au profil peut déjà contenir des données : elles seront remplacées).
    bruno562BZ a dit :
    Si j'ai bien compris rien n'empêche normalement de conserver une base défaut avec des préférences
    Si tu as suivi mon laïus, tout s'y oppose au contraire puisqu'une base ne peut pas s'appeler base défaut (même si tu la renommes : il n'y a pas l'extension .data ; et une base contrairement aux profils ne comporte aucune préférence).

    On ne sauvegarde pas un profil (ni des préférences), on sauvegarde seulement la base .data associée (cad qu'on en fait une copie).

    J'espère que tu y vois mieux...
    (pour résumer : une base Sqlite au format Filmotech comporte les données sur les films (titre, acteurs, réalisateurs, synopsis, etc.), les affiches, et rien d'autre); son nom à l'extension .data.
  • En complément à mon post ci-dessus, comme en informatique on apprend aussi (et surtout) en expérimentant, tu devrais faire une restauration d'un fichier .data dans n'importe quel profil ; par ex, après avoir cliquer sur Restaurer, tu n'hésites pas à cliquer sur Ouvrir  ;) !

  • Bonsoir merci  , je ne sais pas ci je vais m'en sortir , je pense que je vais solliciter mon frère qui est plus expérimenter en informatique .
    Ton schéma ci dessus c'est ce que je fais . Je sauvegarde ma base 76 000 ko dans un dossier que je sais retrouver , je copie ce backup sur clé 
    je l'introduit sur l'ordi concerné . Ensuite clic doit ouvrir avec [ filmotech ]   et il n'apparait pas dans le logiciel . Je vois pas ou je me loupe . Donc cela devrait  changer la base 0 ko ou 30 000 ko     en 76 000 ko . Ou je comprend pas c'est que je l'ai changer déjà ou je me trompe introduit a la création au départ mais cela ne marche même pas . Merci pour le temps que tu passe a essayer de me guider . Dans certains domaines je manque certainement d'expérience .  
  • Bon j'ai pas hésiter à restaurer sur un portable de 1665 fiches je suis passer a 0 fiches . J'aurai du me retrouver avec 3335 fiches , je n'y comprends plus rien . base défaut / restaurer backup ouvrir et hélas 0 fiches . Ce n'est pas l'anti virus qui me fait un tour ?
  • FilmotechFilmotech Administrator
    Il ne faut pas ouvrir une base directement depuis l’explorateur. Il faut lancer Filmotech, aller dans les préférences, sélectionner un profil puis restaurer. C’est à ce moment là que tu sélectionnes le fichier .data que tu veux utiliser. 
  • j'ai désinstallé le logiciel et réinstallé , il a gardé en mémoire la base vide . Sinon il m'aurait dema ndé si j'avais une base a ajouter à l’installation .
    décidément pas de chance . C'est certainement un backup  caché dans le registre .Maintenant c'est bien comme tu disque je procédais . Je ne vais pas restaurer l'ordi à 0 pour effacer ce fichier caché .
  • CarlBernardCarlBernard Member
    1 févr. modifié
    Quand on désinstalle Filmotech, il ne supprime pas les préférences dans le dossier Filmotech_prefs (adresse sur le disque : C:\Utilisateurs\nom_utilisateur\AppData\Roaming\Filmotech_prefs).
    Donc c'est normal que tu retrouves ta base.
    C'est du reste pratique quand on change de version Filmotech : on retrouve toutes ses préférences (dont les bases).
    Il faut supprimer le dossier Filmotech_prefs si tu veux vraiment tout redémarrer à 0.

    Mais je pense que le mieux est que tu te fasses aider sur place, par ex par ton frère comme tu l'as suggéré (il devrait trouver suffisamment d'indications dans cette discussion).
  • Merci j'essayerai de solliciter mon frère quand dispo . Si je trouve ce dossier ça devrait peu être ce résoudre .
  • J'ai du nouveau mais pas concluant . Sur Windows 7 , filmotech 3.9.1  j'ai réussi à effacé tout dans les fichiers cachés donc propre pour nouvelle installation . J'ai réinstallé le logiciel ajouté une première base dans la procédure d’installation et rien n’apparaît .Le chemin  de la base finis bien dans local , j'ai vérifié dans les cachés  76 000 ko . C'est déjà cela je peut tout effacer mais je trouve pas ce qui foire.
  • J'ai du nouveau , j'ai refait la manœuvre plusieurs fois et j'ai réussi sans problème à entrer la base , mais pas celle que tu pense la 76 000 ko ne fonctionne pas . Donc je suis repartis sur une base 12 000 ko ça fonctionne ensuite une base 35 000 ko , ça fonctionne aussi .Maintenant je reviens vers toi , à tu une idée pour ma base 76 000 ko , il n'y a pas possibilité de ce tromper en sauvegardant ? Je te remercie de ta patience c'est un cas
    d'école ou pas ? Si j'avais trouvé comment enlever les fichiers cachés avant il y aurait eu moins de débat . Merci beaucoup .
    Il me reste a refaire la manip sur Windows 10 si je trouve les fichiers cachés ... 
  • CarlBernardCarlBernard Member
    2 févr. modifié
    En fait, comme je ne suis pas devant ton ordi, je ne peux pas vraiment t'aider (montrer comment faire les manips).
    Pour ton frère, déjà l'essentiel est dit (copie d'écran) dès ma première réponse ; tu peux relire pour voir si ça t'éclaire.
    Le fait que le répertoire des préférences soit au départ caché n'est pas vraiment important; une fois qu'on l'utilise, il ne l'est plus ! (et en principe on n'a pas a y intervenir pour restaurer un .data).
  • Je suis entièrement d'accord avec ce que tu me dit simplement je persistait a entrer mon data le plus volumineux sans essayer de rentrer d'autres sauvegardes . mon data 76 000 ne fonctionne pas . J'ai retrouvé un data 60 000 ko ça fonctionne . Simplement ça affiche le nombre de films en bas de l'écran et sur préférence tous mes films  films 0 . je les ai récupérés dans les recherches avancés par lieu de stockage . C'est peu être pas normal mais je me prends plus la tête , merci beaucoup .
  • J'ai un backup 769 films ou tout s'affiche même la section tous mes films , les autres préférences  il y a une mise a jour a chaque ouverture , c'est peut être pour cela que tous mes films affiches 0 films . 
Connectez-vous ou Inscrivez-vous pour répondre.